(18.207.136.189)
Users online: 1948   
Email id
 

BULMIM Journal of Management and Research

Publisher: Bharatiya Vidya Bhavansusha And Lakshmi Mittal Institute Of Management
Print ISSN:
Online ISSN: 2455-3298
Number of issues per year: 2
Print frequency: Half-Yearly
Month(s) of publication: January and July
Description:

BULMIM Journal of Management and Research is a double peer blind review bi-annual publication. It provides a forum for researchers and professionals worldwide by encouraging publication of research paper/ articles/ case studies/ book reviews with emphasis on various management issues. The journal also seeks to strike a balance between theoretical paradigms and business practices by focusing on current and future trends in the area of management. The journal is now being co-published by Indian Journals.com that develops online version and makes it available on famous research portals like - Scientific Journal Impact Factor (SJIF - 5.494), Google Scholar, CNKI Scholar, EBSCO Discovery, I2OR, ESJI, J-Gate, IIJIF and ISRA-JIF. Each research article of the journal has a DOI number also.

    Subscription Rates for the year :2023 Click here to Subscribe now
    Online * Print **
    Institute 1,200.00 2,030.00
    1,200.00 2,030.00

    Online *
    Institute 130.00
    130.00
    Site Licencing Price
    6,000.00 650.00
    For consortia pricing, Please contact at info@indianjournals.com.
     
    Please Note:
    1. * Online subscription rates are inclusive of service tax.
    2. * Online subscription includes limited access (5 concurrent users) of current subscription plus contents published from 2005(If available).
    3. ** Print includes complimentary online limited acess (5 concurrent users).
    For Terms & Conditions. Please click here.

    Top

    ║ Site map ║ Privacy Policy ║ Copyright ║ Terms & Conditions ║ Page Rank Tool
    597,030,948 visitor(s) since 30th May, 2005.
    All rights reserved. Site designed and maintained by DIVA ENTERPRISES PVT. LTD..
    Note: Please use Internet Explorer (6.0 or above). Some functionalities may not work in other browsers.